Project

General

Profile

操作問い合わせ #2430

エージェント実行時のエラーに関して

Added by Anonymous over 2 years ago. Updated over 2 years ago.

Status:
終了
Priority:
通常
Assignee:
-
Start date:
12/27/2016
Due date:
% Done:

0%

Estimated time:

Description

現在Job Arranger for Zabbixの検証を行っております。
初歩的な質問かもしれませんが、ご確認いただけますでしょうか。

以下のコマンドをJobアイコンに登録しテスト実行するとエラーとなります。
-------------
touch /tmp/bbb
-------------
Job ServerとAgentは同一のCentOS7に導入して実行しようとしています。
Agentのログに下記の内容が出力されています。
-------------
4161:20161227:195533.378 [ERROR] In ja_jobfile_chkend() process 6245 isn't existed
4161:20161227:195533.379 [ERROR] In ja_agent_end() Agent does not to run as 'root'
-------------
2行目のエラーはroot権限ではない、との内容ですが権限周りの設定が不足しているでしょうか?
セキュリティ上不必要にroot権限をつけたくないので、confファイルのAllowrootは0のままです。
以上、恐れ入りますがご確認いただけるでしょうか。

History

#1 Updated by 保守サポート 担当 over 2 years ago

  • Status changed from 新規登録 to 回答中

ジョブアレンジャーのご利用ありがとうございます。

当該ジョブアイコンの設定で「実行ユーザー」を指定していませんでしょうか?

AllowRoot=0 で「実行ユーザー」を指定して実行しますとこのエラーが出ます。
「実行ユーザー」を指定するときはAllowRoot=1でのAgent起動が必要です。

実行ユーザーのルールについては下記をご参照ください。
http://ジョブ管理.fitechforce.com/reference-manual_2.1/account_of_job_execution.html

速やかな返信のためにサポート契約をご検討頂ければ幸甚です。
宜しくお願い致します。

#2 Updated by Anonymous over 2 years ago

保守サポートご担当者様
ご回答いただき誠にありがとうございます。

実行ユーザに関して理解しておらず、ご指摘いただいた通りの状態でした。
変更して稼働させてたところ、想定通りに稼働いたしました。
引き続き機能検証を行いたいと思います。

この度はありがとうございました。本件、クローズいただければと思います。

なお、ご紹介いただいたURLを拝見したのですが、1点誤りではないかと
思われる部分がございました。ご確認いただけますと幸いです。

「★Windowsの場合の実行ユーザ」の最初の分岐がいずれも「YES」になっております。

以上、よろしくお願いいたします。

#3 Updated by 保守サポート 担当 over 2 years ago

  • Status changed from 回答中 to 終了

では本件クローズいたします。
またURLのご指摘有難うございました。訂正いたしました。

今後ともJobArrangerをよろしくお願いいたします。

Also available in: Atom PDF