プロジェクト

全般

プロフィール

その他問い合わせ #2956

導入検討にあたってのご質問

匿名ユーザー が23日前に追加. 18日前に更新.

ステータス:
回答中
優先度:
通常
担当者:
-
開始日:
2018/07/30
期日:
進捗率:

0%


説明

現在、Job Arrangerの導入を検討しております。
※導入時のサポート契約等も含めて

検討にあたり情報をいただきたくこちらに投稿させていただきました。
お手数ですが以下のご質問に回答いただけますと助かります。

  • Windowsの同一ホスト上でJob ManagerとJob Agentの同居は可能か
  • 同一ホスト上でJob ServerとZabbixの同居は必須か?
  • Server,Manager,Agent間のバージョンは常にそろえる必要があるか?
    推奨環境でない前提で構わないので、バージョン違いを組み合わせた構成は可能か?
  • Zabbixのバージョンアップが発生した際、Arranger側で作業は必要になるか?
    アップ後のバージョンがJob Arrangerに対応していれば特に作業は不要か?
  • 障害発生箇所からジョブネットを再実行する際、
    例えば再実行した時刻の関係でフロー上の特定のジョブを
    実行しない、といった設定は可能か?

お手数ですがご回答をお願いいたします。

履歴

#1 保守サポート 担当22日前に更新

  • ステータス新規登録 から 回答中 に変更

Job Arranger導入のご検討、大変ありがとうございます。

•Windowsの同一ホスト上でJob ManagerとJob Agentの同居は可能か

可能です。

•同一ホスト上でJob ServerとZabbixの同居は必須か?

必須ではありません。
Zabbixデータベース上にJob Arrangerデータを作成することは必須ですが、Job Serverは別で問題ありません。
↓参考
https://www.jobarranger.info/jaz/jaz_system.html

•Server,Manager,Agent間のバージョンは常にそろえる必要があるか?
推奨環境でない前提で構わないので、バージョン違いを組み合わせた構成は可能か?

これはサーバの稼働環境のバージョンについての質問ですね?
その場合バージョンをそろえる必要はありません。
一例ですがServerがCentOS7で、AgentがRedhatでも、CentOS5や6でも問題ありませんし、ManagerがWindows7や10、Agentが各種Windows Server でも大丈夫です。

•Zabbixのバージョンアップが発生した際、Arranger側で作業は必要になるか?
アップ後のバージョンがJob Arrangerに対応していれば特に作業は不要か?

Zabbixのバージョンアップをされた際でも、Arranger側でバージョンアップの必要はありません。
Job Arrangerで利用するZabbixバージョンの指定が可能です。
https://www.jobarranger.info/jaz/jaz_env.html

•障害発生箇所からジョブネットを再実行する際、
例えば再実行した時刻の関係でフロー上の特定のジョブを
実行しない、といった設定は可能か?

可能です。一例ですが、
・マニュアル再実行であれば特定のジョブをスキップしてその後続を実行可能。
・フロー上で時間等の条件によってフローの分岐も可能。

今後のサポート契約に関するお問合せにつきましては以下をご利用ください。
https://www.jobarranger.info/mail/index.cgi

以上よろしくお願いいたします。

#2 匿名ユーザー が22日前に更新

早々にご回答いただきありがとうございます。
1点だけ想定と違う回答でしたのでお手数ですが再度ご確認をお願いできますでしょうか?

•Server,Manager,Agent間のバージョンは常にそろえる必要があるか?
推奨環境でない前提で構わないので、バージョン違いを組み合わせた構成は可能か?

こちらでお尋ねしている「バージョン」はJob Arrangerのバージョンを指しています。

過去のチケットでマネージャとサーバは同じバージョンのJob Arrangerを導入する必要があるが、
エージェントは違うバージョンでもよい、といった回答を拝見したので質問させていただきました。

質問の意図として導入が決まった場合、エージェントの数が膨大になる可能性があるため、
サーバ(マネージャ)のバージョンアップが発生した場合にエージェントも
全台一斉にバージョンアップする必要があるかどうかを懸念しています。

推奨はされていないものの暫定的に稼働可能なのであれば、
エージェントのバージョンアップは順次実施、といった方針のもとで
導入の検討ができるため、お答えいただけますと幸いです。

#3 保守サポート 担当22日前に更新

失礼いたしました。
#2930 での回答ですね。
Job Arranger Agentのバージョンがサーバより下位バージョンでも問題ない旨回答しており、その通りです。

但しAgentの新バージョンで実現した新機能や改善は入りませんので、
それらが必要な場合で必要とするAgentには、出来るだけ早くバージョンアップをお願いいたします。

エージェントのバージョンアップは順次実施、といった方針

このご想定での導入は問題ありません。

以上よろしくお願いいたします。

#4 匿名ユーザー が21日前に更新

ご回答ありがとうございます。

追加の確認になるのですが、バージョンが違う場合での
運用となった場合に最低限メジャーバージョンはあわせる必要がある、
といった制限事項はございますでしょうか?

サーバ、マネージャ:3.X
エージェント:2.X

といった組み合わせは可能なのでしょうか?

質問の意図としては導入後、メジャーバージョンのアップデート(仮に4.X)が
発生した場合についてはエージェントの合わせて4.Xにする必要がある、
といったことが必要かを懸念しております。
メジャー、マイナーに関係なく、既存機能については
稼働可能という認識で問題ないかご教示いただけますでしょうか。

追加の質問となり恐縮ですが、ご回答のほどお願いいたします。

#5 匿名ユーザー が20日前に更新

更に追加の質問で恐縮です。

例えば、Windowsのタスクスケジューラのセキュリティオプションで
設定するような実行時のユーザを指定する、といった機能はございますでしょうか?
※Windows含めて対応できるかご教示ください。

#6 保守サポート 担当19日前に更新

ご確認有難うございました。

運用となった場合に最低限メジャーバージョンはあわせる必要がある、
といった制限事項はございますでしょうか?

そういった制限事項はこれまではございません。
今後もバージョンアップでも同様にしていく予定ですが、
新しいバージョンの改訂には導入すべきものもあり得ますのでご確認ください。

サーバ、マネージャ:3.X
エージェント:2.X
といった組み合わせは可能なのでしょうか?

可能ですが、2.X以降で追加の機能や改善は使えないものはありますのでご留意ください。

設定するような実行時のユーザを指定する、といった機能はございますでしょうか?
※Windows含めて対応できるかご教示ください。

ジョブアイコンで実行ユーザを指定できます。
https://www.jobarranger.info/jaz/reference-manual_3.2/jobnet_icon_job.html

以上よろしくお願いいたします。

#7 匿名ユーザー が18日前に更新

ご回答ありがとうございます。

一旦、お聞きしたいことはすべて確認できましたので
本件はクローズいただいて大丈夫です。

また、導入検討にあたり追加の質問等があれば
別途ご相談させていただきます。

丁寧なご対応ありがとうございました。

他の形式にエクスポート: Atom PDF