Project

General

Profile

Edit Actions

その他問い合わせ #3671

closed

Job Arranger Agent 6.0 ソースコードインストールについて

Added by Anonymous about 1 year ago. Updated 9 months ago.

Status:
終了
Priority:
高め
Assignee:
-
Start date:
06/22/2023

Description

同一のジョブ実行サーバにJAZ Agent 3.2とJAZ Agent6.0を共存させようと考えております。
共存させるにあたり、現在、JAZ Agent 6.0 のソースコードインストールについての検証を行っております。

JAZ Agent 3.2がインストールされているRHEL 7.3 に対してJAZ Agent 6.0 のソースコードインストールを実施したところ、
json-c、libtar、automake の3つのパッケージに起因するエラーが発生しました。

過去に似たような事例として、コミュニケーションサイトに#922、#1264等がありましたので、
こちらを参考に下記3つをソースコードインストールしたところ、JAZ Agent 6.0をインストールすることが出来ました。

<対象ライブラリ、ツール>
・json-c 0.12
・libtar 1.2.20
・automake 1.16

※json-c と libtar 、automakeはそれぞれ ver 0.11, ver 1.2.11, ver 1.13 が既にインストールされている状態でしたが、
 インストール済みのものは削除せずに、上記バージョン(json-c 0.12、libtar 1.2.20、automake 1.16)をソースコードインストールしました。

■質問1
JAZ Agent 3.2とJAZ Agent6.0を共存させることによる不具合など、情報はございますでしょうか。
共存せることは可能でしょうか。

■質問2
ライブラリやツールのバージョンが新しくなることによるシステムやAgentの不具合を懸念しており、
本番環境には可能な限り新しいプログラムは導入したくないと考えております。
上記json-c、libtar、automakeをAgentインストール後に削除することを検討しているのですが、
削除することによるエージェントの不具合等はありますでしょうか。

■質問3
RHEL7.3以外の下記バージョンについてもAgentのソースコードインストールを予定しており、
RHELバージョンそれぞれで上記と同等のインストール作業が必要と考えております。

・RHEL 7.2
・RHEL 6.7
・RHEL 6.5
・RHEL 5.6
・RHEL 5.3

各RHELバージョン毎のjson-c、libtar、automakeのAgent 6.0への対応バージョンについて何か情報をお持ちでしょうか。
<対象ライブラリ、ツール>に記載しているバージョンと同じでよろしいでしょうか。

■質問4
上記各RHELバージョンに対してJAZ Agent 6.0をソースコードインストールする際の
その他注意点等ございましたら、ご教示いただけますと幸いです。

お手数ですが、回答が可能なものからで構いませんので、上記4点のご回答をお願いいたします。

Updated by 保守サポート 担当2 about 1 year ago

■質問1
JAZ Agent 3.2とJAZ Agent6.0を共存させることによる不具合など、情報はございますでしょうか。
共存せることは可能でしょうか。

多分、実行環境の事を言われているのだと思います。別プロセスですので、共存可能です。
■質問2
ライブラリやツールのバージョンが新しくなることによるシステムやAgentの不具合を懸念しており、
本番環境には可能な限り新しいプログラムは導入したくないと考えております。
上記json-c、libtar、automakeをAgentインストール後に削除することを検討しているのですが、
削除することによるエージェントの不具合等はありますでしょうか。

Build環境と、実行環境を一緒にして言われているのだと思いますが、実行オブジェクトは、上記のライブラリを実行オブジェクトに取り込みますので、実行時には、必要ありません。
■質問3
RHEL7.3以外の下記バージョンについてもAgentのソースコードインストールを予定しており、
RHELバージョンそれぞれで上記と同等のインストール作業が必要と考えております。

・RHEL 7.2
・RHEL 6.7
・RHEL 6.5
・RHEL 5.6
・RHEL 5.3

各RHELバージョン毎のjson-c、libtar、automakeのAgent 6.0への対応バージョンについて何か情報をお持ちでしょうか。
<対象ライブラリ、ツール>に記載しているバージョンと同じでよろしいでしょう

RHEL6.x , 5.xについては、対象外OS Versionになりますので、こちらでは確認しておりません。
■質問4
上記各RHELバージョンに対してJAZ Agent 6.0をソースコードインストールする際の
その他注意点等ございましたら、ご教示いただけますと幸いです。

特にありません。
Actions #2

Updated by 保守サポート 担当2 about 1 year ago

  • Status changed from 新規登録 to 回答中

Updated by 保守サポート 担当2 9 months ago

  • Status changed from 回答中 to 終了

長期間更新がありませんので、Closeします。

Edit Actions

Also available in: Atom PDF