Project

General

Profile

Edit Actions

操作問い合わせ #3658

closed

JobArranger バージョン関連のご質問(アップグレード・互換性)

Added by Anonymous over 1 year ago. Updated 8 months ago.

Status:
終了
Priority:
通常
Assignee:
-
Start date:
03/22/2023

Description

現在、一部のシステムにおいてJobArrangerのManager/Server/Agentのそれぞれを、バージョン3.0.0で利用しております。
アップグレードに伴いいくつかご不明点ございますので、ご質問させてください。
なお、5.*台で稼働しているシステムもあるため、5.*台へのアップグレードを検討中です。


段階的なバージョンアップも視野に入れて検討しており、Manager/Server/Agentの互換性を気にしています。
Managerを5.0.0、Server/Agentを3.0.0など、メジャーバージョンが異なる状態では動作可能でしょうか。


https://www.jobarranger.info/document/doku.php?id=upgrade:upgrade
上記アップグレード手順を確認させていただきましたが、3.2.0 or 3.4.0からの4.*へのアップグレード手順はありますが、
3.0.0から他のバージョンへアップグレードする手順が見当たらないように思われます。
こちら、手順などございますでしょうか。
3.2.0 or 3.4.0からのアップグレード手順をそのまま利用可能でしたら、そのような回答でも問題ございません。

以上、よろしくお願いいたします。

Updated by 保守サポート 担当 about 1 year ago

  • Status changed from 新規登録 to 回答中

ジョブアレンジャーのご利用ありがとうございます。


段階的なバージョンアップも視野に入れて検討しており、Manager/Server/Agentの互換性を気にしています。
Managerを5.0.0、Server/Agentを3.0.0など、メジャーバージョンが異なる状態では動作可能でしょうか。

ManagerはServerで利用するDBのバージョンと合わせる必要がございますので、ManagerとServerは同一バージョンをご利用ください。

JobAgentはJobServer対して基本的には下位互換があります。
但し利用するアイコンでのJobAgent<-->JobServer間のインターフェースに関わる更新が入っているものは更新バージョン以降で合わせる必要がございます。
ジョブネットに使用しているアイコンに依りますので事前の稼働確認が必要です。

またJobAgent5.1.0はJobServer4.1以降であれば稼働可です。
https://www.jobarranger.info/jaz/jaz_release_note.html#side600t


https://www.jobarranger.info/document/doku.php?id=upgrade:upgrade
上記アップグレード手順を確認させていただきましたが、3.2.0 or 3.4.0からの4.*へのアップグレード手順はありますが、
3.0.0から他のバージョンへアップグレードする手順が見当たらないように思われます。
こちら、手順などございますでしょうか。
3.2.0 or 3.4.0からのアップグレード手順をそのまま利用可能でしたら、そのような回答でも問題ございません。

3.0.0からのアップグレードでは以下の3.ver 2.1.0⇒3.2.0,3.4.0の手順のdatabaseのupgradeが必要です。
3.2.0 or 3.4.0からのアップグレード手順にこのdatabaseのupgradeを入れてください。
https://www.jobarranger.info/document/doku.php?id=upgrade:04upgrade2-1-0_3-2-0

速やかな返信・対応のためにサポート契約をご検討頂ければ幸甚です。
宜しくお願い致します。

Updated by 保守サポート 担当2 11 months ago

更新が無ければCloseします

Actions #3

Updated by 保守サポート 担当2 8 months ago

  • Status changed from 回答中 to 終了
Edit Actions

Also available in: Atom PDF