Project

General

Profile

Edit Actions

その他問い合わせ #3699

closed

JobArrangerManager ログインエラー

Added by Anonymous 8 months ago. Updated 5 months ago.

Status:
終了
Priority:
高め
Assignee:
-
Start date:
10/19/2023

Description

お世話になります。

Redhat9でJobArrangerサーバを構築しています。
バージョン6.1.0
ブラウザでジョブマネージャのセットアップが正常に完了してその後ログイン画面が表示され、ログインしようとすると下記のエラーが表示されログインができません。

ERROR Invalid parameter "/": unexpected parameter "user".

ログ出力をDEBUGモードに変更するとジョブマネージャログに下記が出力されました。
何が原因かわかりますでしょうか?
なおログインしようとするユーザはZabbix上に存在するユーザとなります。デフォルトAdminや新規作成したユーザでも同様のエラーが表示される状況です。

■jobarg_manager.log
691:20231019:073210.578 [DEBUG] [] [App\Utils\Database::__construct()] DB is successfully connected.
691:20231019:073210.590 [INFO] [] [App\Controllers\Users::login()] User login process is started.
691:20231019:073210.730 [INFO] [] [App\Controllers\Users::login()] Invalid parameter "/": unexpected parameter "user".

Updated by 保守サポート 担当2 8 months ago

Zabbix APIが異なるようみえます。
利用されているZabbix Versionを教えて下さい。

Updated by Anonymous 8 months ago

Verはこちらになります。ご確認のほどよろしくお願い致します。

  1. zabbix_server -V
    zabbix_server (Zabbix) 6.4.7
    Revision 4e555c6d64d 26 September 2023, compilation time: Sep 26 2023 00:00:00

Copyright (C) 2023 Zabbix SIA
License GPLv2+: GNU GPL version 2 or later <https://www.gnu.org/licenses/&gt;.
This is free software: you are free to change and redistribute it according to
the license. There is NO WARRANTY, to the extent permitted by law.

This product includes software developed by the OpenSSL Project
for use in the OpenSSL Toolkit (http://www.openssl.org/).

Compiled with OpenSSL 3.0.7 1 Nov 2022
Running with OpenSSL 3.0.7 1 Nov 2022

  1. rpm -qa |grep zabbix
    zabbix-server-mysql-6.4.7-release1.el9.x86_64
    zabbix-web-6.4.7-release1.el9.noarch
    zabbix-agent-6.4.7-release1.el9.x86_64
    zabbix-web-mysql-6.4.7-release1.el9.noarch
    zabbix-web-deps-6.4.7-release1.el9.noarch
    zabbix-apache-conf-6.4.7-release1.el9.noarch
    zabbix-sql-scripts-6.4.7-release1.el9.noarch
    zabbix-selinux-policy-6.4.7-release1.el9.x86_64
    zabbix-web-japanese-6.4.7-release1.el9.noarch
  1. rpm -qa |grep jobarranger
    jobarranger-server-mysql-6.1.0-1.el9.x86_64
    jobarranger-manager-6.1.0-1.el9.x86_64

Updated by 保守サポート 担当2 8 months ago

  • Status changed from 新規登録 to 回答中

Zabbix Severは、6.0.xに対応となります。Zabbix 6.4.xは、Table構造が変更されていますので、対応しておりません。

下記を参照してください
https://www.jobarranger.info/jaz/jaz_env.html

Updated by 保守サポート 担当2 5 months ago

  • Status changed from 回答中 to 終了

更新が無いのでCloseします。

Edit Actions

Also available in: Atom PDF