Project

General

Profile

Edit Actions

操作問い合わせ #3716

closed

JAZインストール後にログインに失敗する(500エラー)

Added by Anonymous 5 months ago. Updated 5 months ago.

Status:
終了
Priority:
通常
Assignee:
-
Start date:
01/22/2024

Description

Zabbix 6.0.25にJAZ 6.1.1をインストールしましたが、
JAZ ManagerのWebログイン画面にて、Zabbixの管理者ユーザIDとパスワードを入力してログインを試みたところ

"500 internal server error"

が応答され、ログインが出来ません。

ただし、JAZ側のログ(/var/log/jobarranger/jobarranger/jobarg_manager-2024-xx-xx.log)には以下のような記録が残っています。

2584:20240122:054616.989 [INFO] [] [App\Controllers\Users::login()] Authentication is success.
2584:20240122:054620.793 [INFO] [] [Router::resolve()] Invalid Json Format.
2719:20240122:055425.280 [INFO] [] [App\Controllers\Users::login()] User login process is started.
2719:20240122:055425.381 [INFO] [] [App\Controllers\Users::login()] Authentication is success.
514:20240122:060006.387 [INFO] [] [Router::resolve()] Invalid Json Format.
894:20240122:060015.203 [INFO] [] [App\Controllers\Users::login()] User login process is started.
894:20240122:060015.316 [INFO] [] [App\Controllers\Users::login()] Authentication is success.
528:20240122:060051.490 [INFO] [] [Router::resolve()] Invalid Json Format.
528:20240122:060054.335 [INFO] [] [App\Controllers\Users::login()] User login process is started.
528:20240122:060054.430 [INFO] [] [App\Controllers\Users::login()] Authentication is success.
895:20240122:060116.602 [INFO] [] [Router::resolve()] Invalid Json Format.
895:20240122:060120.035 [INFO] [] [App\Controllers\Users::login()] User login process is started.
895:20240122:060120.131 [INFO] [] [App\Controllers\Users::login()] Authentication is success.
520:20240122:060632.627 [INFO] [] [Router::resolve()] Invalid Json Format.
895:20240122:060642.127 [INFO] [] [App\Controllers\Users::login()] User login process is started.
895:20240122:060642.219 [INFO] [] [App\Controllers\Users::login()] Authentication is success.


Files

audit.log (10 KB) audit.log Anonymous, 01/24/2024 01:37 PM
Actions #1

Updated by 保守サポート 担当2 5 months ago

  • Status changed from 新規登録 to 受付完了

Updated by 保守サポート 担当2 5 months ago

  • Status changed from 受付完了 to 担当者処理中

Zabbixへのログイン認証は、終了しているようにみえます。

監査関係のauditログをuploadして頂けないでしょうか?
通常ですと、/var/log/audit/audit.log になります。

Updated by Anonymous 5 months ago

audit.logが見当たらないです。

ubuntu@ip-172-30-2-195:~$ sudo ls /var/log
alternatives.log cloud-init.log dpkg.log syslog
amazon dist-upgrade jobarranger ubuntu-advantage.log
apache2 dmesg journal unattended-upgrades
apt dmesg.0 kern.log wtmp
auth.log dmesg.1.gz landscape zabbix
btmp dmesg.2.gz lastlog
chrony dmesg.3.gz mysql
cloud-init-output.log dmesg.4.gz private
ubuntu@ip-172-30-2-195:~$ sudo find / -name audit.log
ubuntu@ip-172-30-2-195:~$
ubuntu@ip-172-30-2-195:~$

Updated by Anonymous 5 months ago

auditdをインストールして、500エラーを再現しました。

Updated by Anonymous 5 months ago

こちらの件ですが、

OSを変更(Ubuntu 22.04 → CentOS Stream 9)して再インストールしても同じ事象が生じています。

SElinuxを無効化していますし、Auduitログにdeniedの記録も発生していませんが、
関係ありそうなログが

/var/log/httpd/error_logに記録されています。このログはJobarranger managerにログインを試みて500 errorが発生するたびに記録されているようです。

[Tue Jan 30 16:59:56.325374 2024] [proxy_fcgi:error] [pid 19121:tid 19173] [client ::1:35958] AH01071: Got error 'PHP message: PHP Notice: Parameter "/user" is deprecated. in /usr/share/zabbix/include/classes/validators/CApiInputValidator.php on line 1330PHP message: PHP Notice: Non-boolean flags are deprecated. in /usr/share/zabbix/include/classes/validators/CApiInputValidator.php on line 1221'

以下はZabbixのバージョンになります。このバージョンはjobarranger 6.1のサポート対象のバージョンという認識です。 **********************************************************************
[root@ip-172-30-2-82 httpd]# zabbix_server -V
zabbix_server (Zabbix) 6.0.26
Revision 623853f8d6f 29 January 2024, compilation time: Jan 29 2024 00:00:00

Copyright (C) 2024 Zabbix SIA
License GPLv2+: GNU GPL version 2 or later <https://www.gnu.org/licenses/&gt;.
This is free software: you are free to change and redistribute it according to
the license. There is NO WARRANTY, to the extent permitted by law.

This product includes software developed by the OpenSSL Project
for use in the OpenSSL Toolkit (http://www.openssl.org/).

Compiled with OpenSSL 3.0.7 1 Nov 2022
Running with OpenSSL 3.0.7 1 Nov 2022

Updated by Anonymous 5 months ago

情報ありがとうございます。
御利用になられているPHPのVersionを教えていただけますでしょうか。

Updated by Anonymous 5 months ago

phpのバージョンはこちらになります。

サポート対象という認識です。

[root@ip-172-30-2-82 ~]# php -v
PHP 8.1.14 (cli) (built: Jan 4 2023 17:23:14) (NTS gcc x86_64)
Copyright (c) The PHP Group
Zend Engine v4.1.14, Copyright (c) Zend Technologies

Updated by 保守サポート 担当2 5 months ago

Job Arrangerのテーブルは、Zabbix Databaseに入れられてますでしょうか?

Updated by Anonymous 5 months ago

解決しました。
原因はJobarranger serverのインストールが未完了でした。
お手数をおかけしました。
ありがとうございました。

Actions #10

Updated by 保守サポート 担当2 5 months ago

  • Status changed from 担当者処理中 to 終了
Edit Actions

Also available in: Atom PDF